SharePoint 2010: Howto disable My Site and My Profile link

By | October 10, 2010

English:

This is graphical guidelines to disable My Site or My Profile link in a portal.

 

1. Open Central Administration , and click on “Manage service applications”.

HideMySite1

 

2. Open Central Administration , and click on “Manage service applications”.

HideMySite2

 

3. Click on “Manage User Permissions”

HideMySite3

 

4. Remove “Use Personal Features” permission for the Groups/Users.

HideMySite5

5. If you can’t see the new rules being reflected in the site. You can restart “User Profile Service”

HideMySite7     HideMySite8

6. And now, the users will not be able to see My Site / My Profiles link.

HideMySite9

14 thoughts on “SharePoint 2010: Howto disable My Site and My Profile link

  1. Pingback: Howto: Disable MySite or My Links – link | Ideas For Free

  2. Pingback: Tweets that mention SharePoint 2010: Howto disable My Site and My Profile link | Ideas For Free -- Topsy.com

  3. cakriwut Post author

    We are not creating personal sites. Every users will create their own personal site.

    Reply
  4. Will

    These instructions will also disable mysites pages.
    I would like to know how to just remove the links from the menu while the pages are still active.

    Reply
  5. Will

    I figured out how to do it. You just uncheck use social features.
    However, the My Sites and My Profiles link will still show in the Welcome Menu on the Search page.

    Reply
  6. Pen Moor

    In IE8, simply zooming the window to 125% will have the same effect, so watch out!

    Reply
  7. murat

    Any idea how to host MySite on root site (same web app. with root Collobration site) exm: http://portal/sites/mysite –> what happens if I let users to create their "my content" I mean I set MySite Host –> http://portal/sites/mysite and Personal Site Location –> personal.
    But I get an error with title of
    "The security validation for this page is invalid. Click Back in your Web browser, refresh the page, and try your operation again." 
    Any advice?
    Thanks.

    Reply
  8. murat

    I ment to say that
    My root site: http://portal
    MySite Host URL: http://portal/sites/mysite
    I am hosting My site at same web application with root Portal, and created another site colelction with url http://portal/sites/mysite at same web application with Root site.
    But I am not able to create MyContent sites.
    When I try to open MyContent MySite asks me language sellection, after selecting language an error page appears says:
    "The security validation for this page is invalid. Click Back in your Web browser, refresh the page, and try your operation again."
    Thanks.

    Reply
  9. Pingback: HowTO: Customize WELCOME menu items « Working with SharePoint

  10. AKM

    I followed these steps, still i am seeing the my site and my profile links. Do I have to check any thing else?
    Thanks

    Reply
  11. Pingback: Hide my site link with css « Share… What?

Leave a Reply